SocialEngine Blog

SocialEngine is the best way to create a unique community website. Let your friends, fans or customers geek out about anything you want.

SE4 Release Candidate 1

The first SocialEngine 4 release candidate (RC1) has been posted and is available for download from the client area. This latest release includes many important features and bug fixes so we highly recommend installing or upgrading. We’ve been working hard on the finishing touches of SocialEngine 4 and we hope to have the final release ready in the next couple weeks!

30 Comments

  1. Nagendra
    Posted June 19, 2010 at 2:01 am | Permalink

    Thanks for your Work.

  2. Nick S.
    Posted June 19, 2010 at 4:07 am | Permalink

    You guys work very fast. Can't wait for the finial release! :)

  3. nadri
    Posted June 19, 2010 at 8:33 am | Permalink

    Nice work..:)
    We will test this version in real enviroments soon…
    I wonder about mods for v4…

  4. KK
    Posted June 19, 2010 at 8:42 am | Permalink

    What about an open preview for non costumers?

  5. Daniel
    Posted June 19, 2010 at 9:34 am | Permalink

    Bring it! Thanks team!

  6. Virgil
    Posted June 19, 2010 at 9:55 am | Permalink

    Hello,

    I try to install it on shared hostgator hosting but don t work because the script ask permission 777 and the most hosting give 755…

  7. behrooz
    Posted June 19, 2010 at 10:02 am | Permalink

    thank you for your hard work
    i want to ask about upgrade script from version 3.XX to 4.XX plz do not forget to work on it.

  8. Peer
    Posted June 19, 2010 at 1:24 pm | Permalink

    Hi,

    great news.

    As as potential customer it would be great to see a demo site. When will you publish such a demo site?

    BR

  9. umicom
    Posted June 19, 2010 at 3:27 pm | Permalink

    Hi
    Can anyone tell me how I can get SE4 to work? I cant seem to get any of the releases to work at all, Just installed RC1 and still having same issue that it does not load any of the CSS files

    please take a look at the link http://www.umicom.com/socialengine

    I would be grateful if you can help me out with this issue

  10. umicom
    Posted June 19, 2010 at 7:28 pm | Permalink

    Just found out how to sort out my own problem, for anyone whom might be in the same situtation, basically I just switched between development mode to production mode and it worked :)

    can't wait for the final release to update my main site :)

  11. Daniel
    Posted June 19, 2010 at 10:27 pm | Permalink

    Getting something like this while upgrading?

    Warning: Zend_Loader::include(Engine/Package/Manifest/Parser/Com/httpdocs/se/temporary/package/packages/core/.php

    It seems that whatever namespace goes first will find its filters with no problems, second or subsequent namespaces result in a warning message even though it correctly loads the builtin Zend/Filter/Alpha.php
    The desired behaviour is that no warning message would be generated.

    The problem can be easily fixed by putting an @ in front of the include statement in line 83 of Zend/Loader.php
    because in Zend/Filter.php the class loader blindly tries namespaces in order: (snippet below from that file, line 172ff)

  12. SE FAN
    Posted June 20, 2010 at 6:09 am | Permalink

    i very hope if SE v.4 can upgradeable from v 3.xx

    this is most important for us that already have large network…

    Thanks

  13. movie6
    Posted June 20, 2010 at 7:52 am | Permalink

    I am always looking at your news releases for info on SE4 and yes I would also like a preview of SE4 before I buy. Can you please post a preview for non customers? Thanks

  14. clasificados
    Posted June 21, 2010 at 1:21 am | Permalink

    Greatest social networking software ever!!!

    Congrats again guys.

    Clasificados

  15. Denver Wilcox
    Posted June 21, 2010 at 4:38 am | Permalink

    SE4 is looking great. At the moment my biggest concern is the site search. On SE3 results are divided into the plug-ins under tabs. It doesn't appear on the SE4 demo.

    I am building a new website and this feature plays a big part in how I have structured my web site. It is a unique feature that helps me differentiate myself from my competitors.

    I hope it will still be available with SE4, at least as an option, or if it is not available and necessary could code be copied across from SE3 to SE4 to enable this function. Can you please comment.

  16. Cuentas Anuales
    Posted June 21, 2010 at 7:19 am | Permalink

    Good news!

  17. Mark
    Posted June 21, 2010 at 9:03 am | Permalink

    I agree with movie6, you need to upload a preview. I need to start building a new social network in a week or so, and if there is no preview or final release, I will have no choice but to go with phpFox.

  18. Mat
    Posted June 21, 2010 at 11:59 am | Permalink

    Another shout here for a public demo.

    I've been watching the development of the new version for a while as I have a need for a Zend Framework based social script for an ongoing project. Very excited about Social Engine as a contender for this and looking forward to seeing a demo in due course.

  19. Steve
    Posted June 21, 2010 at 12:59 pm | Permalink

    For those looking for a demo site, check out the Support link above and look at the SocialEngine Mechanic community. There is a link to a demo of RC1 that you can at least see the front end features.

  20. Alvi
    Posted June 22, 2010 at 2:13 am | Permalink
  21. IdleHearts
    Posted June 23, 2010 at 11:46 am | Permalink

    Installed V4 RC1 @ http://www.idlehearts.com

  22. Blackgold
    Posted June 23, 2010 at 11:04 pm | Permalink

    This is now much better than the beta versions great Job guys adn gals of the Webligo Team.
    My only concern so far is if I want to upload an image for the Site Title how can i do that as the field for the title can't take images. Is there a way to do it.

  23. Ashley
    Posted June 24, 2010 at 8:16 pm | Permalink

    The way I have added a logo is to goto ->

    /application/modules/Core/widgets/menu-logo/index.tpl

    Remove ->

    <?php $title = Engine_Api::_()->getApi('settings', 'core')->getSetting('core_general_site_title', $this->translate('_SITE_TITLE')) ?>
    <?php $route = $this->viewer()->getIdentity()
    ? array('route'=>'user_general', 'action'=>'home')
    : array('route'=>'core_home'); ?>
    <?php echo $this->htmlLink($route, $title) ?>

    And replace with ->

    <img src="logo.gif" />

    Upload logo.gif to your root folder :)

    Hope this helps!

    Ashley

  24. Jeramy
    Posted June 25, 2010 at 3:45 am | Permalink

    I'm trying my best to edit the themes, but it only makes the change once and then nothing happens to the themes no matter what I do to them afterwards. I'm using the online editor provided. Is anyone else having this problem?

  25. jose
    Posted June 25, 2010 at 5:09 pm | Permalink

    This is now much better than the beta versions great Job guys adn gals of the Webligo Team. My only concern so far is if I want to upload an image for the Site Title how can i do that as the field for the title can't take images. Is there a way to do it.

    In the admin panel is not showing how many users are connected.
    Nor is who of my friends is online nor in the search.

  26. Brandon
    Posted June 26, 2010 at 4:15 am | Permalink

    Yo when will the se4 demo be released i would like to see it so i can purchase se4

  27. adikhresna
    Posted June 26, 2010 at 6:54 am | Permalink

    I try to install a fresh SE4_RC1. Can anyone help me how to get it work? Or have to I try SE3.20?

  28. Eddie
    Posted June 27, 2010 at 7:49 am | Permalink

    @ Ashley:

    Simply go to layouts In your ACP, open the Header page, remove their logo and place a HTML block there Instead, then It's as easy as <img src="http://www.yoursite.com/yourlogo.png"&gt;, perhaps throw a div tag In, so you can div align, or even easier, just <center> It's that simple, no need to change or remove code. I explained this on socialenginebase.

  29. phamhphuc
    Posted June 27, 2010 at 4:05 pm | Permalink

    Is plugin forum available for SE4 now?

  30. Ashley
    Posted June 28, 2010 at 7:56 pm | Permalink

    @eddie

    Thanks, I tried adding a html block first but couldnt get it to align exactly where I wanted it so had to opt for the hard coding option :)

    Does anyone know when final release & upgrade script from se3 will be available?

    Thanks

Post a Comment

You must be logged in to Post a Comment.