SocialEngine Blog

SocialEngine is the best way to create a unique community website. Let your friends, fans or customers geek out about anything you want.

SocialEngine 4 Migration Script

We’re happy to announce the release of the SocialEngine 3 to 4 migration script, now available for download. There are some important notes in the instructions so please read carefully.

The migration script is relatively simple to run and instructions are included. If you’d prefer to have the service performed for you, there are two options available:

1. Starting Monday, Aug 16, we’ll be offering a migration service for $60. Note that the turnaround on this service could be up to 3-5 business days because of the high volume that’s anticipated.

2. Newrosoft have offered their services and are available for installation and migration starting from $29.95. They can be contacted at se4services@newrosoftmods.com.

Let us know what you think and we look forward to welcoming new clients to SE4!

24 Comments

  1. Gregory
    Posted August 13, 2010 at 4:58 am | Permalink

    If you have been tinkering with SE4 and don't want to lose your test settings…do not forget to backup your SE4 database before you import. Luckily I remembered because the import did not go smooth so I can revert and try again later.

    None of my user passwords came through and none of my group posts. Also, I used new admin accounts in me SE4 testing. Just like the instructions say… this import reverts all your user accounts to SE3 users.

    Be safe and backup before you jump in with both feet. I am going to bed and try tackling this over the weekend. Thank you Webligo for outputting errors during the import. This will help me figure what went wrong.

    By the way Webligo, is there any reason we can't run SE4 in a folder forever? (or at least until SE5?) Thanks!

  2. Amr
    Posted August 13, 2010 at 9:12 am | Permalink

    Thank you Noam and all the team for your hard work. Will the script copy the translations or not?

  3. Neiler
    Posted August 13, 2010 at 10:35 am | Permalink

    Thanks guys for working so hard on the migration script , now go out and relax it's the weekend, you deserve it šŸ˜‰

  4. pat
    Posted August 13, 2010 at 12:27 pm | Permalink

    we love u guys

  5. baru
    Posted August 13, 2010 at 8:13 pm | Permalink

    SE3 to SE4 upgrade script Problems
    –>Not importing user passwords.
    –>Not importing album photos.
    –>Not importing videos.
    –>and etc…

    @Noam please fix these problems

  6. Noam
    Posted August 13, 2010 at 8:20 pm | Permalink

    @baru We'd be happy to look in to import issues – please submit a bug report using our website contact form. Thanks!

    @pat Thanks, we love you too!

    @Neiler We'll try. :) Thanks for the pat on the back.

    @Gregory Yes, you can run SE4 in a folder, that isn't a problem. Feel free to submit any bugs you come across.

  7. Irnis
    Posted August 13, 2010 at 9:52 pm | Permalink

    ty for migrate script its really easy to figure out but stil cant find socialengine3 pathy way :( so my import is (0)

  8. Andrey
    Posted August 14, 2010 at 5:44 am | Permalink

    SE3 to SE4 upgrade script Problems –>Not importing user passwords.

  9. slim
    Posted August 14, 2010 at 12:58 pm | Permalink

    Baru is right exact problem with me it creates another table in sql with user pass named migration user but credentials not working, music imported buy music plug-in is not working after importing it, it imports albums but no pics in it it gives error try allocating XXX bytes or some times it says 500 internal server error while importing pics, so it don`t goes on next step to import videos!

  10. Jeffrey
    Posted August 16, 2010 at 7:36 pm | Permalink

    I had no problem using the migration script it was quite easy to use but not everything transfered over. All of my pages are missing. Why did the plugins not migrate over? Can you fix this is here at socialengine r can someone tell me how to install the missing plugins in 4?

  11. Ana
    Posted August 16, 2010 at 9:16 pm | Permalink

    Hi,

    This tool does not import the passwords, now how do we solve this problem?
    I wish I could have for the site online with version 4.
    Anyway everything is 5star.

    Good work.

  12. Paul
    Posted August 17, 2010 at 2:26 am | Permalink

    Hello, all passwords not working in my new installation of social engine 4 please, help me

  13. patrick
    Posted August 17, 2010 at 2:50 am | Permalink

    has anybody migrated successfully? users can't login, all the plugins and their contents won't migrate. Can Noam help us? I love your work.

  14. Gregory
    Posted August 17, 2010 at 2:40 pm | Permalink

    Hey everyone! There is a new step 3 to the import process (see KB instructions). This fixed my SE3 passwords problem. I think my last import problem is probably because I have a lot of user fields.

    @Noam… you should probably let everyone know when SE posts a fix. I had to find out about it in forum.

  15. Noam
    Posted August 17, 2010 at 10:27 pm | Permalink

    As mentioned, for anyone with password issues during the migration, check out the updated KB article. Step 3 should fix those issues.

  16. Larry
    Posted August 17, 2010 at 11:43 pm | Permalink

    Noam i see that you are publishing everyone elses comments about teh migration but i am yet to see any of the two that i sent in. As i said in my second comment and to which i sent in the error code attached the music migration is not workign at all. It would be nice to see both the good and bad comments published…. Any idea when / if you will respond to my earlier comment or have a fix for it.

  17. Noam
    Posted August 18, 2010 at 12:55 am | Permalink

    @Larry We do try to post all comments that are relevant to the topic, but this isn't the proper channel for bug reports. Please submit them using the bug submit feature of our contact form (http://www.socialengine.net/contact). Thanks!

  18. David
    Posted August 18, 2010 at 11:02 am | Permalink

    Is it normal that it runs over seven hours? (Had to close it) seems like it goes in circles

  19. Noam
    Posted August 18, 2010 at 7:17 pm | Permalink

    @Louise Yes, the script can take a long time to process based on how many users you have.

  20. Britt
    Posted August 19, 2010 at 12:18 am | Permalink

    Hi, just upgraded from 2.x through to 4. Went reasonably smoothly and the majority of the errors were around plugins not yet added.

    Giving the website a cursory review however has uncovered some basic problems such as:
    * profile name and info missing
    * edit profile won't let info be added manually (not that I would want to with 4000+ members

    I think apart from that it's okay. I can manually create a script to import the missing data but thought it might be a known problem with a workaround?

    Cheers,
    Jase. (on behalf of dogtree)

  21. Posted October 16, 2014 at 1:51 am | Permalink

    Hi.

    Can somebody please have a look at this
    Website that I am trying to migrate to another server. I did all the
    steps mentioned in this forum but I couldnĀ“t manage to get the home page
    content fully visible.

    Here are both links to both the original website and the website being migrated:

    http://dehilos.com/

    http://159.253.144.75/~dehilos/

    If you need more details please let me know.

    I would really depreciate your help.

  22. Posted October 16, 2014 at 11:28 am | Permalink

    Hi Mustafa,

    A great place to post this would be at community.socialengine.com where SE users can interact.

    If you’re not a member of the community yet, simple request it and we’ll get you in.

    James

  23. Posted October 18, 2014 at 1:39 am | Permalink

    Hi James,
    I have tried many times to register but I didnĀ“t see any options for that. All what I can see is a login link. Thanks

  24. Posted October 19, 2014 at 10:46 pm | Permalink

    Hi Mustafa, I have sent you an invite. Please check the email you use for Disqus.

Post a Comment

You must be logged in to Post a Comment.