SocialEngine Blog

SocialEngine is the best way to create a unique community website. Let your friends, fans or customers geek out about anything you want.

SocialEngine 4.2 – reCAPTCHA, Wibiya and a Simple, Clean Theme

Please refer to this link for the 4.2.1 release.

Thank you all for a great 2011! We’ve released some awesome features with 4.2, as well as the usual flurry of bug fixes and tweaks. These are core features, so they are free for all of you!

4.2 is now available to download in the client area, and we will be releasing the 4.2 trial within a week. As always, please be sure to backup your database before upgrading or making any changes!

List of features:

  • reCAPTCHA – Free service that will help prevent spam bots from registering on your SocialEngine site.
  • Clean Theme – Alex designed a new theme focused on simplicity. Try it for yourself. We know you’ll love it!
  • Wibiya – an online toolbar platform that offers SocialEngine publishers the option to add web applications to their respective websites. Increase communication within your community!

Take a peek at our CHANGELOG for the complete list of updates.

Please contact us if you have any questions!

52 Comments

  1. Stars
    Posted January 12, 2012 at 3:31 am | Permalink

    Janrain social login and builtin reCaptcha is good addition, You should add Network Selection option in Activity Feed & Content Upload/Sharing so member can share content with Specific Network (Not all network they joined)

  2. Dan
    Posted January 12, 2012 at 3:35 am | Permalink

    Kudos!

  3. Posted January 12, 2012 at 4:01 am | Permalink

    GREAT UPGRADES

  4. David
    Posted January 12, 2012 at 4:30 am | Permalink

    Great news! Please add a blog post to know if 4.1x plugins are compatible or if we need to wait for updates from the dev community.

  5. Vahdet
    Posted January 12, 2012 at 4:55 am | Permalink

    thanksss alottt :)))

  6. Posted January 12, 2012 at 5:08 am | Permalink

    The new features are awesome! So, I have my site running 4.1.8p1 (full package)… but I don't know how to update to 4.2 release… can you help me? Thanks in advance!

  7. Alberto
    Posted January 12, 2012 at 5:15 am | Permalink

    I can not understand the Janrain and webiya addition… why are you filling SE with paid crap, you have an small but very good developers community and I think you sometimes steps over their toes. 4.2 must be a version of SE that fixes the bugs of previous versions, not just a new version with more crappy things… sorry to be rough with you guys but is what I feel and i think that is what most of the others may feel too.

  8. Kristina
    Posted January 12, 2012 at 5:23 am | Permalink

    I upgraded to version 4.2, but my theme is remaining the same as 4.18. I am very sad… Any one help with an advice why that is happened and how to fix it? Pleazzze!

  9. rony
    Posted January 12, 2012 at 5:34 am | Permalink

    Thank you for your effort.
    Just a suggestion please:
    From the Admin page, if you select any member then press delete selected members, would be good to have a message (Are you sure you want to delete the selected members).

    Also we need more generous Themes, more lively colours (different than than the standard White & Blue).

    Any possible way to see from the Admin page the members who are only, currently it display the number of Online members but we need to see who is Online (member name or id).

    Thank you SE fro all your efforts.

  10. Yateesh
    Posted January 12, 2012 at 6:34 am | Permalink

    The 4.2 upgrade file does not contain the Clean Theme. Please correct this..

  11. Thomas
    Posted January 12, 2012 at 7:02 am | Permalink

    We really like this theme, looks totally professional.

  12. Charles
    Posted January 12, 2012 at 7:16 am | Permalink

    Would be fantastic if you could incorporate some functionality, so that when a user comes to the website the most popular members/recent sign-up list could be restricted to their country. I think this geo functionality would really help to encourage signups for us anyway. Any chance for the next version?

  13. Ifat
    Posted January 12, 2012 at 9:38 am | Permalink

    While upgrading I get this message:
    "These system requirements must to continue with this installation:
    • module-payment-4.2.0 : MCrypt
    We recommend installing the mcrypt extension. Your payment gateway login information will be stored encrypted if this extension is available.
    • module-storage-4.2.0 : SSH2
    The SSH2 extension is required for CDNs that use SSH or SCP."

    What does this actually mean?
    What do I do to get these modules? I looked for them in the list of tar's but they aren't listed

  14. Posted January 12, 2012 at 12:49 pm | Permalink

    Re-Captcha and Janrain features are pretty good and required for the community.Keep up the good work :)

  15. Posted January 12, 2012 at 12:58 pm | Permalink

    where can i find upgrade instructions?

  16. MICROTECH PRODUCTOS INFORMATICOS SL
    Posted January 12, 2012 at 2:14 pm | Permalink

    Great job!! thanks

  17. Posted January 12, 2012 at 2:25 pm | Permalink

    Has any development of this upgrade compromised the functionality of 3rd party plugins?

  18. Posted January 12, 2012 at 3:12 pm | Permalink

    We have checked all our modules and themes with SocialEngine 4.2. All of them works without any issues. Nice update SE team!

  19. Ermir
    Posted January 12, 2012 at 3:14 pm | Permalink

    Thank you SE !

  20. Luis
    Posted January 12, 2012 at 3:47 pm | Permalink

    Hello,

    When I try to do the upgrade to v4.2, the system tells me that the file rpx_xdcomm.html is not writable. But when I try to change the permissions on this file to 0777, the system returns the file permissions to 0644.

    How I can you fix this issue?

    Thanks,
    Luis

  21. Julie
    Posted January 12, 2012 at 4:07 pm | Permalink

    It's great to have updates, but I always get surprises when doing so and what is supposed to be a free update comes at the end as a very expensive one as it takes time to go over the issues an update gives us.

    As for now when editing profile, the "edit photo" tab is gone. And if there was any other tab there, it's gone as well, only profiles questions are left.

    Any advice besides the one I will leave for everyone here: if you can't pay SE support everytime there's an update, dont update.

  22. servant
    Posted January 12, 2012 at 5:26 pm | Permalink

    i have the probleme with : Storage 4.1.8p1
    Warning: Your database structure for this package is out of date. The version you currently have is 4.1.1. Please complete the installation of this package to resolve this problem.

    error :

    Query failed with error: Mysqli statement execute error : Duplicate key name 'plugin'

  23. Carlo
    Posted January 12, 2012 at 5:45 pm | Permalink

    Nice one guys, thanks for the update.
    Would be nice, maybe it's already available to have a more detailed breakdown then the change log to help us layman better understand the changes?
    Look forward to seeing what's still coming!
    Cheers again

  24. Ash
    Posted January 12, 2012 at 8:48 pm | Permalink

    Upgrade seemed to install OK, but the drop-down menu in the admin section has disappeared. Also happened under the last upgrade, which is why I have been waiting for this latest one. Any ideas why the main menu under admin would just vanish?

  25. Posted January 12, 2012 at 9:23 pm | Permalink

    Thank you

  26. Matt
    Posted January 12, 2012 at 11:18 pm | Permalink

    For those who have upgraded and would like to try the Clean Theme, please download it here: http://www.socialengine.net/support/article?q=215&question=Updating-Themes

  27. Darren
    Posted January 12, 2012 at 11:58 pm | Permalink

    Thanks SE – upgraded no problems at all. Re-Captcha is a god send :)

  28. Posted January 13, 2012 at 12:33 am | Permalink

    Upgrade was smooth….Easiest so far! Page speed score plunged from B/87% to F/46%. Page upload speed slightly improved from 1.7s to 1.5s. Still testing it out.

  29. Jeff
    Posted January 13, 2012 at 5:19 am | Permalink

    Tacking on third-party products like Captcha and Janrain are alright for some, I suppose, but we are in desperate need of better core functionality like and an improved search function (like Lucene). I would appreciate more focus on the core of your system vs. focusing on third-party integration.

  30. Posted January 13, 2012 at 3:14 pm | Permalink

    Can you give feature to give captcha for blog posting like facebook giving ? my site is suffering for unnecessary blog post from some china people.

  31. Posted January 13, 2012 at 3:32 pm | Permalink

    Nice upgrades but the Wibiya toolbar is make anything that is tabbed not to work? We need a fix! I have had other sites and I know it is the Wibiya bar

  32. Matt
    Posted January 13, 2012 at 10:40 pm | Permalink

    Please put Wibiya into no-conflict mode if you are using the Wibiya toolbar and have problems with profile tabs.

    As always, please submit support tickets or contact us if you have questions and would like assistance. http://www.socialengine.net/contact

  33. Kainoa
    Posted January 14, 2012 at 1:42 am | Permalink

    No conflict mode? Well, Jquery should be the default javascript library to be using. I hate mootools! Jquery has more functionality and is the most popular javascript library in todays web.

    Do your product a favor and kill Mootools. Enough said!

  34. Posted January 14, 2012 at 12:36 pm | Permalink

    All three are good to have. My Janrain social login icons are very small. Is there a way to configure the display size?

  35. Martin
    Posted January 14, 2012 at 6:40 pm | Permalink

    /Agree with Alberto and Jeff.

    Third party add on services I think need to be left out, as you have a great development team and awesome developers behind SE.. Focus on improving core, releasing better themes (paid or free) without adding optional services, particularly paid services in the core, but instead, modules for them..

    Member search needs some major revamp…

  36. Posted January 16, 2012 at 11:15 am | Permalink

    I get the error rpx_xdcomm.html is not writable. I can not find that file. Where is it?

  37. Glenn Norvic
    Posted January 16, 2012 at 3:29 pm | Permalink

    One of my concerns right now is an API or some tutorials for devs to easily integrate SE4 on static pages or even on WordPress widgets. Like if you want a login field to be shown on an outside page and have you still shown as "logged in" to your site.

    Also, please fix the line breaks at the site. Currently its still messed up as extra br tags appear per line break.

  38. Peter K.
    Posted January 17, 2012 at 11:36 am | Permalink

    Please – how can i install this version as it comes as a zip and not a tar file i cannot use the previous way! Thanks for advice!

  39. Tayyab
    Posted January 17, 2012 at 7:49 pm | Permalink

    KeyCaptcha is better to integrate, its better spam prevention

  40. Nicholas
    Posted January 18, 2012 at 12:30 am | Permalink

    Thanks for the update. All are appreciated a lot. I plan to start development in April, I hope. I hope It's not to late for the 2012 Mayan calendar! =D

  41. Matt
    Posted January 18, 2012 at 1:03 am | Permalink

    If the crossdomain.xml amd the rpx_xdcomm.html is not writable, we suggest extracting the files from the 4.2 zip file, and uploading it to your root server manually. Afterwards, please be sure to set the file permission to 777.

    @Peter the 4.2 .tar is available to download from your account area.

    As always, please submit a support ticket or contact us to receive assistance. http://www.socialengine.net/contact

  42. Posted January 18, 2012 at 4:43 pm | Permalink

    @Tayyab,
    KeyCaptcha loads spam directly into browsers of visitors from their servers in exchange of blocking it from website and webmaster can't control or even see it

    Consult their website. Devs offer all network of protected websites for advertising. Though they do not have advertisers yet

  43. Philippe
    Posted January 18, 2012 at 6:30 pm | Permalink

    BTW there's CDN issue with the Chat, all emoticons are not loaded or transfered to the CDN

  44. juan antonio
    Posted January 18, 2012 at 8:47 pm | Permalink

    hello, because the administration website i get advertising (powered by)

  45. Derrick
    Posted January 20, 2012 at 1:35 pm | Permalink

    hey SE4

    A vital part of our community is our users pictures, We need a AUTO PHOTO RE-SIZER for you photo album plugin to maintain a consistent picture quality never degrading from its imported source, I purchased a few third party plugins from our top community developers they said quality starts with the initial plugin.

    other wise
    Great improvements

  46. Posted January 21, 2012 at 6:39 pm | Permalink

    Hello, SE team!

    Update goes smooth, thanks!
    We like integration of great 3rd part services a lot.

    When you will create special "feature requests" section for clients? :)

    Here is another one:
    Please make possible create sub-categories in Classifieds.
    We are use outdated DP plugin now but we want such feature in the SE core.
    Sub-categories are vital for any content section of the site.
    We glad that Radcodes got it in last update (we use Article plugin) – better later than never 😉
    Please, make us happy too :)
    Thanks!

  47. Stephen
    Posted January 22, 2012 at 3:52 pm | Permalink

    Hi im new to SE4 and does anyone have a "how to" guide to upgrade the package to 4.2? thanks in advance…

  48. Martin
    Posted January 22, 2012 at 11:47 pm | Permalink

    and then.. the more external junk we add, the slower the site will get get.

  49. Posted January 26, 2012 at 10:31 pm | Permalink

    Wibiya broke half the site, anything that slides or is tabbed broke. We had to disable it. Any ideas?

  50. Jose D
    Posted January 28, 2012 at 1:53 am | Permalink

    I had to write to Webiya Support team, tab on the chat with friends does not work correctly. Their response were that they had problems with it and were working to fix it.

  51. Posted January 30, 2012 at 4:38 pm | Permalink

    First, let me say that I love SE4.2, but I do have some issues after upgrading and integrating Wibiya. The Wibiya toolbar covers up the SE IM bar and it conflicts so that photos can not be uploaded to the site (almost all modules). I did click on no conflict mode, but this did not help. I have submitted a support ticket, but just wanted to let everyone know that they may have the same issues with Wibiya.

  52. Philippe
    Posted January 31, 2012 at 6:04 pm | Permalink

    In the next update you should add MySQL Database Replication, and all the external plugin like Janrain or Wibiya should be added externally the core module, instead as an App.

Post a Comment

You must be logged in to Post a Comment.