SocialEngine Blog

TinyMCE Update

Hey community builders,

We got a lot of great feedback on our recent SocialEngine PHP 4.7 release. We found that some people encountered issues with the new TinyMCE editor in the Blogs plugin, which made it hard for end-users to post photos.

We heard you guys loud and clear and have been working on a patch. Today we have released an update for our Blogs Plugins (v4.7.1) which restores the file upload functionality in TinyMCE. You can download the free update from your client dashboard. The update comes with setup instructions and should be very easy to install. Thanks again to all of you that are helping us make SocialEngine better every day.

  • http://www.retbranche.com/ RetBranche.com

    keep it up

  • Pg Top

    Why don’t you guys make the TinyMce image upload plugin (jbimages) part of the SE core file so that other 3rd party developers can make use of it as well, instead releasing it as part of the Blog? Now, if any other plugins want to use this feature, they would either need to make Blog v4.7.1 (min) as their requirements OR would have to put the same code into their own plugins creating another mess. This is unacceptable!

    • es7

      That’s a really good point. As 3rd party devs we gladly use unified libraries if they are available.

      • Andrés

        This will come on next release.

        • thatmtnman

          an extreamly important update you guys! It was like being in the 1990′s all over again using the current version!

        • AdVertu

          When this happens?

        • Kris

          Do you plan to use MoxieManager or jbimages?

  • vinienco

    they will not post my comments as they dont want criticism made public.

  • Scherer Peter

    How can I do this in the groups and Forum installing so that you can then upload pictures?

  • Tzolkin Man

    Yes I don’t understand why anyone would make this process so difficult, every other CMS out their has no problems with tinyMCE but hey… as a possible solution I have found a free filemanager but I don’t know how to make it work with SE 4.7 or tinyMCE but it looks promising, if anyone can decipher how to make it work with se4.7 please share it, here is the site where you can get the free open source filemanager for tinyMCE 4 http://responsivefilemanager.com/index.php#prettyPhoto

  • skidpics

    It doesn’t show images in messaging even though you use the toolbar to add the images.. It shows it but just shows the html code once you send the message.

  • http://www.facerex.com/ facerex

    how can I correct this error?

    Parse error: syntax error, unexpected T_STRING, expecting ‘)’ in /home/fa/public_html/application/languages/en/en.php on line 2459

    • http://socialengine.com/ Kyle

      Could you do us a favor and email us over at sales@socialengine.com? I’ll make sure to forward this issue to the proper tech support staff.

  • Ferry

    Why isn’t there a discussionboard for people to post suggestions or idea’s? And maybe it would be usefull that people can vote on posts so the best idea’s will be inserted in the social engine script?

    • http://socialengine.com/ Kyle

      We definitely want to hear your feedback and hear about what you want to see in future versions of the software! Go ahead and sign up over at community.socialengine.com and post your requests there. We regularly monitor this community to see what our developers need for future versions!

  • Bajan Fire Fighters

    Just realize that my ‘Manage Plugins’ link does not work… when I click
    on this link it just takes me back to ‘Control Panel’. I need help,
    can’t upload new themes.

    • http://socialengine.com/ Kyle

      Hello! For this issue it would be best to open a support ticket from your client dashboard at SocialEngine.com/client. This will allow our technicians to diagnose and help fix this issue.

  • skidpics

    When is the next PHP update coming out? Any major enhancements?

  • EL

    Hey Guys!

    I am having issues uploading an image from TinyMce image upload plugin since the day I installed it.

    Ii keeps showing its uploading even for the smallest file size.

    I have attached snapshot of the same.

    ==========================================
    Upload in progress…
    This is taking longer than usual.
    An error may have occurred.
    View script’s output….. And When I view I see the below message:

    We’re sorry!

    We are currently experiencing some technical issues. Please try again or report this to your site administrator using the contact form.

    Administrator: Please check the error log in your admin panel for more information regarding this error.

    Error Code: b95f93

    =====================================

    Please help….

    • http://socialengine.com/ Kyle

      I’m sorry to hear about that. If you could, go ahead and open a support ticket from your client dashboard. This will bring the issue to the attention to our support technicians who will be reaching out as soon as possible!

  • http://www.MMAMELEE.com/ MMA Melee™

    Someone please help when i go to admin panel Manage plugins/packages etc it will show the link .com/admin/packages but when i click it it takes me back to .com/admin every time and will not let me access the packages or plugins….anyone else having this issue? i want to update to this now but it won’t let me access