SocialEngine Blog

SocialEngine is the best way to create a unique community website. Let your friends, fans or customers geek out about anything you want.

SocialEngine PHP 4.9.1p1 Patch Release

Hello,

We noticed an issue that precipitated an immediate release. This 4.9.1p1 release patch fixes an issue with photo album privacy on the profile.

Changed files:

  • application/modules/Album/Model/DbTable/Albums.php
    • Fixing profile album issue
  • application/modules/Album/controllers/IndexController.php
    • Fixing search related issues

You can download your copy of this patch from your client account. The file will be Photo Albums 4.9.1p1.  No need to run the full upgrade if you already have upgraded to 4.9.1.

To upgrade versions below 4.9.1, please view our upgrade documentation or, if you’d rather we take care of the hard stuff, you can order an upgrade and we’ll do it for you. Fresh installs should follow this installation tutorial or you can order an installation ticket and our team will get it installed in no time! Please note that those upgrading from versions below 4.9.1 do need to get all of the files and not just the photo album files. This patch relates to version 4.9.1 and not lower versions.

NOTE: Please make sure that you do a complete backup of both files and database before performing an upgrade. Please have the backup performed by your host or a developer if you’re not comfortable with performing it yourself.

Thank you all for your help in posting any bugs you may have found! If you find any more issues, please let us know by filing a bug report in our Public Bug Tracker or by contacting us here. Lastly we’d like to encourage you to stay connected with the community.

With Great Appreciation,

The SocialEngine Team

 

3 Comments

  1. Posted May 1, 2017 at 3:13 am | Permalink

    Can you please try scrolling horizontally towards right to view rest of the menu items. Our technician says you shouldn’t face the issue again after. If you still have any issue, please contact support along with a screenshot.

  2. Posted May 1, 2017 at 7:37 pm | Permalink

    I received this error trying to update. I have never received a database error trying to upgrade and I’ve had SE since 3.0. Thank any suggestions will help. I appreciate your time and fast response. https://uploads.disquscdn.com/images/116d724bbe5b8d84d64e086ed237b32246a78aad1aeeb783b4c56fbaf871834d.png

  3. Posted May 2, 2017 at 7:44 am | Permalink

    Hi,

    In the future, you would get a faster response if you post in our community or in a ticket as the blogs are just comments and not given as high a priority. :)
    Regarding your issue, please see a patch in our bug report, https://github.com/SocialEngine/phpv4-issues/issues/724 and please let us know in that bug report if the patch works fine for you. Thank you!

Post a Comment

Your email is kept private. Required fields are marked *

*
*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>