SocialEngine Blog

SocialEngine is the best way to create a unique community website. Let your friends, fans or customers geek out about anything you want.

SocialEngine PHP 4.9.2 Release

SocialEngine 4

Hello!

We’re back with another release, SocialEngine PHP 4.9.2! This minor release addresses some issues that were reported by clients in our Github and also that our staff found during further testing. We’ve also included some minor improvements to current features. Please be sure to read the special instructions below before upgrading.

Fixed Issues or Improvements Made:

  • Fixed issue with privacy for video browse and videos on profile similar to the photo privacy fixed for 4.9.1.
  • Fixed privacy issue for Email being passed in verification URL. (Fixes #493)
  • Fixed issue where privacy options were not showing on the user profile. (Fixes #713 )
  • Fixed spelling error on the performance caching overview page. (Fixes #694)
  • Fixed TinyMCE editor formatting issue in announcements. (Fixes #669)
  • Fixed TinyMCE and BBCode editor formatting issue in forum. (Fixes #719)
  • Fixed issue with networks that caused sorting in Admin not to work on next pages.
  • Improved banner CTA button background to be more visible.
  • Fixed Viglink settings and description in Admin Panel.
  • Fixed issue with editing post from notification. (Fixes #732)
  • Issue: Some server configurations caused settings files to be deleted upon upgrade. Solution: We improved the upgrade routine to skip any files in the application/settings/ folder. (Improvement #724) **See instructions below for this fix
  • Improved display of long user profile photos on members home page by using cropped thumbnails. (Improvement #139)

NOTE: Please make sure that you do a complete backup of both files and database before performing this upgrade. Please have the backup performed by your host or a developer if you’re not comfortable with performing it yourself.

**Special upgrade instructions -DO NOT SKIP THIS STEP-

We’ve included a special patch (not necessary for fresh installs) that you can download in step one below, but this patch does involve a couple of vital steps. If these steps are not followed it may appear as if your database has been deleted. This patch addresses an issue with some server configurations but is best for all clients to apply before upgrading. This manual patch is for any version and can be applied by following the steps below.

  1. Download the patch .
  2. Unzip the file.
  3. Upload the unzipped files to your server, where you have SocialEngine installed (in most cases this would be the public_html or httpdocs folder), before upgrading. Make sure you overwrite the original file.
  4. Clear cache.
  5. Follow the standard upgrade procedure to upgrade your site.

You can also browse the complete changelog for more details about the changes and fixes implemented in this version.

We’ve also upgraded Albums, Forums, Music and Videos plugins to 4.9.2.

You can download your copy of version 4.9.2 from your client account. To upgrade, please view our upgrade documentation or, if you’d rather we take care of the hard stuff, you can order an upgrade and we’ll do it for you. Fresh installs should follow this installation tutorial or you can order an installation ticket and our team will get it installed in no time!

Thank you all for your help in posting any bugs you may have found! If you find any more issues, please let us know by filing a bug report in our Public Bug Tracker or by contacting us here. Lastly we’d like to encourage you to stay connected with the community.

With Great Respect,

The SocialEngine Team

22 Comments

  1. Kev Gahan
    Posted May 17, 2017 at 1:41 pm | Permalink

    should i install SocialEngine PHP 4.9.1p1 Patch
    then SocialEngine PHP 4.9.2 Release
    as i still on 4.9 Release

    • Posted May 18, 2017 at 7:51 am | Permalink

      Hi Kev,

      No, you won’t need to as the patch is in the 4.9.2 photo albums plugin download. Please be sure to follow the special instructions in the blog and apply the new patch mentioned before upgrading as it’s for something else.

  2. Aleksey Volkov
    Posted May 18, 2017 at 6:10 am | Permalink

    Thanks, good job!

  3. pableteac
    Posted May 19, 2017 at 5:34 pm | Permalink

    Php upgrade is a only file with format ‘2P1′ ?

    • Posted May 22, 2017 at 8:04 am | Permalink

      Hi,

      I’m not sure what you mean but the file is Social Engine PHP Upgrade (4.X – 4.9.2p1).

      • pableteac
        Posted May 22, 2017 at 8:09 am | Permalink

        It’ all ok. Is that before inside the upgrade zip archive there were more files and now only one but i upgrade sucessfull. Thank’s

        • Posted May 23, 2017 at 8:13 am | Permalink

          Ok that’s great to hear! Have a great day.

  4. Bob Dennis
    Posted May 23, 2017 at 9:53 am | Permalink

    We’ve experienced issues with mass mailing members, which is now stopping all interaction. Will upgrading to 4-9-2 rectify this?

    • Posted May 24, 2017 at 7:49 am | Permalink

      Hi Bob,

      As I’m not having that issue on my 4.8.13 or 4.9.2 sites, I cannot say for sure if it would help the issue on your site. We do recommend upgrading to keep up with current code and bug fixes. If you upgrade and find that your mail issue still exists, please feel free to submit a support ticket via your client dashboard so our team can assist. If you don’t have active support, you can also extend support access via your client dashboard.

      Have a good day!

      • Bob Dennis
        Posted May 24, 2017 at 10:22 am | Permalink

        Hi Donna, I have been working on this this afternoon, only I have limited abilities on such matters. What appears to be the problem is there is no background activities registering at all and emails seem to be stuck in a Que. The last contact was March 15th 2017. Since then, no one has been receiving alerts.

        Thanks, Bob

        • Posted May 25, 2017 at 7:53 am | Permalink

          Hi Bob,

          As our blog is just for simple comments, would you please either raise this at our community or in a support ticket? It will be much easier to assist you in either of those areas.

          Thank you!

  5. Rajesh Rathor
    Posted May 26, 2017 at 1:03 am | Permalink

    I want to join the community but unable to do that?
    It saying , Please request an invitation to join our community. but don’t know how to do that? https://uploads.disquscdn.com/images/6f97715c5995e2177ed7e14e4764c1b27f686aab015874bb3a05aadf43d48060.png

  6. Ken Leeks
    Posted May 27, 2017 at 7:54 am | Permalink

    Hello,

    Any SE page that has the new “Column Width Modifier” widget activated will prevent most javascript to stop working.

    https://uploads.disquscdn.com/images/9ddd1afa38fafcd049a25fa9aca8aef6e16d01e8fdf7697ae1d4f89855a8d2da.png

    https://uploads.disquscdn.com/images/c9156a0660fb9693b6e126cd42c6d92804e8c91f938771a901822bb8736b152f.png

    Will upgrading to 4.9.2p1 resolve this issue? Any info on this is greatly appreciated.

    • Posted May 30, 2017 at 8:13 am | Permalink

      Hi Ken,

      Thank you for reporting this issue. Please note that a link to our Github to report bugs is always in our release blogs so you can see which bugs are reported already and to report those you may find. This makes bug fixing go faster.

      As this bug was not reported before, I’ve added it to our internal list to fix. We hope to have it done for our next release.

      For now, you’ll want to disable the column width modifier.

      Thank you again for your feedback.

      • Ken Leeks
        Posted May 31, 2017 at 3:31 pm | Permalink

        Thanks for the reply, Donna.

        I disabled that widget and won’t use it until it’s fixed. But there’s another issue I’m experiencing with 4.9.x compared to 4.8.12 and that is selecting for a widget to display on mobile devices or not. It doesn’t work. I am running 4.9.x on PHP 5.3, not sure if that makes a difference but yes, widget mobile display doesn’t work for me.

        https://uploads.disquscdn.com/images/8fda2902755e9374ca95897efc699265281d3b5f9502cdc25836509095c7258e.png

        But I can add this issue to your Github

        • Posted June 1, 2017 at 7:59 am | Permalink

          Make sure you have the mobile plugin enabled as it requires that for this setting to work.

          • Ken Leeks
            Posted June 1, 2017 at 11:43 am | Permalink

            Is this a new requirement? Because the same setting worked without any mobile plugin in 4.8.12.

          • Posted June 2, 2017 at 7:48 am | Permalink

            As far as I know, it’s always been a requirement. That is what I had been told before anyway. Please try with the mobile plugin enabled and if it doesn’t work still, please feel free to either comment in our community or post a bug in our github as the blog comments are not the best place for discussing issues as we don’t respond as quickly and it’s much harder to resolve possible issues here. :)

  7. websites
    Posted July 21, 2017 at 6:21 am | Permalink

    Facing an issue after upgradation on BMM.co.in

    I can view the homepage when logged in as admin but can’t do it when not logged in.

Post a Comment

Your email is kept private. Required fields are marked *

*
*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>