SocialEngine Blog

SocialEngine is the best way to create a unique community website. Let your friends, fans or customers geek out about anything you want.

4.10 Roadmap

410roadmap

Hello!

It’s time for a roadmap! We know how much you look forward to new releases and in getting information for upcoming ones. We wanted to let you know what’s on tap for version 4.10 and a basic idea of when to expect it.

New Features

Tagging Members

Ability to tag a member in a post or comment. Username tagging is popular in social networking and it’s coming to SocialEngine PHP 4.10!

Smileys/Emoticons

Smileys/Emoticons are a staple of social networking. We’re including smiley/emoticon support for all text areas!

Profile and Group Banners

We will be adding support for banner images for both individual and group profiles. This adds a customization feature that members tend to love.

Hashtags

We’re adding hashtags! Similar to how Twitter #hashtags work, this will also include a tag cloud to show all of the hashtags added. This is great for SEO and user engagement.

Enhancements

Remove Flash

Remove flash components and replace with HTML5. This is something that clients have requested and we find it necessary due to browser changes. It’s not something we could release in a 4.9 minor release as it’s a big change so we will include it in 4.10.

Networks Update

We’ll be updating Networks so that it’s a more robust feature. Members will be able to choose which of their networks they want to post to (via standard privacy settings).

Profile Types Update

Profile Types is getting some attention. We’ll add the ability to hide on registration and/or member browse, allow admin to assign profile types and edit a member’s profile type.

Remove Old Themes

We will remove the old themes from the core download. These will be added to the marketplace as free, unsupported downloads. Experts are free to update them as they choose and can contact us for details.

PHP Requirements

PHP has come a long way since PHP 5.2 and we find it necessary to update the requirements for SocialEngine PHP version 4.10. It will require at least PHP 5.6 but we strongly recommend using PHP 7.

All of the above are in addition to bug fixes that we’ll incorporate into this version. We anticipate this release during 4th quarter 2017. Got questions? Please feel free to ask at our community!

30 Comments

  1. The Chaosrift
    Posted August 10, 2017 at 11:43 am | Permalink

    On the line of Networks. I LOVE this feature, but it’s so lacking.

    I’d love to have the ability to group members by Age groups. 18-25, 20-30 and so on… At the current state I have to input Birthday month, day, year ranges and constantly adjust. Instead of a member automatically aging out when they hit 30…

    I found a way to edit the code to display their age instead of birthday, but Networks doesn’t have those options.

  2. Peter Panpyt
    Posted August 10, 2017 at 12:04 pm | Permalink

    I think that it would be great if we can change the chat theme on the build in messenger that can fit your look and theme and feel of the site.

  3. Peter Panpyt
    Posted August 10, 2017 at 12:04 pm | Permalink

    also video messaging and live video broadcast.

  4. CodeBlue
    Posted August 10, 2017 at 6:08 pm | Permalink

    Can we use PHP 7 now?

  5. Posted August 11, 2017 at 3:18 am | Permalink

    Yes, SEPHP 4.9.0 introduced support for PHP7.

  6. Posted August 11, 2017 at 3:19 am | Permalink

    Hi Peter,
    Please post feature requests at our community. :)
    Thanks for your feedback!

  7. Posted August 11, 2017 at 3:20 am | Permalink

    Glad you like Networks! We are starting out with these improvements. Please be sure to put your feature requests at our community or comment in one if it’s already there. :) As we make more improvements, we’ll be looking there for requests and creating polls to get more feedback.

  8. Posted August 11, 2017 at 6:34 am | Permalink

    Seems like SocialEngine 4.10 release has something bigger stored in for the community users! The new features are quite impressive, waiting for another sneak peak for this release. Kudos to SocialEngine team for their hard work.

  9. CodeBlue
    Posted August 11, 2017 at 7:28 am | Permalink

    Thank you

  10. Godrifle
    Posted August 11, 2017 at 10:57 am | Permalink

    I know it’s a big ask, but we really need to get to a more modern version of MooTools.

  11. Peter Panpyt
    Posted August 12, 2017 at 12:47 pm | Permalink

    you got the link where i go to to post feature request?

  12. Peter Panpyt
    Posted August 12, 2017 at 12:50 pm | Permalink

    will 4.10 support HTML 5

  13. Meister G
    Posted August 13, 2017 at 12:57 am | Permalink

    Finally, some much needed love! I hope you guys use Emoji 2.3 or 3.1 or those Twitter emojis would make the script very attractive to begin with :)

  14. Haitham M. Nazzal
    Posted August 13, 2017 at 2:41 am | Permalink

    How we can upgrade for new version?

  15. Marc Chinama
    Posted August 13, 2017 at 7:20 am | Permalink

    Removing flash, thank you. Flash is by far the worst of the worst. HTML5 will be great for those who want games. I guess I’ll be removing my games.

  16. Armend Derguti
    Posted August 13, 2017 at 8:49 am | Permalink

    Hello, Glad to see that next version is about to come! I would like to strongly propose a new admin panel similar to SE Cloud. There is a lot to be improved on the current admin panel but whatever gets improved I will be happy. good luck

  17. Posted August 14, 2017 at 11:05 am | Permalink

    Thank you for your feedback. For feature requests, please post at the community linked in the blog. Thank you!

  18. Posted August 14, 2017 at 11:05 am | Permalink

    Thank you for your feedback Marc!

  19. Posted August 14, 2017 at 11:06 am | Permalink

    Please post questions at our community or please contact our support. Note that you cannot upgrade to 4.10 until we release it. This is just a roadmap. :)

  20. Posted August 14, 2017 at 11:06 am | Permalink

    Thank you for your feedback :)

  21. Posted August 14, 2017 at 11:06 am | Permalink

    Yes it will.

  22. Posted August 14, 2017 at 11:07 am | Permalink

    Please go to the link in the blog for our community. The feature request area is there. :)

  23. Posted August 14, 2017 at 11:07 am | Permalink

    Hi,
    Thanks for your feedback. Please post feature requests at our community linked in the blog.

  24. Posted August 14, 2017 at 11:08 am | Permalink

    :) You’re welcome!

  25. Posted August 14, 2017 at 11:08 am | Permalink

    Thank you for your feedback!

  26. Ian Charles
    Posted August 15, 2017 at 10:30 pm | Permalink

    Would like to know how this is going to affect my 3rd party theme! I would prefer to use the themes that are on the site but it kind of limited. Do you know if they’re going to have new themes or updates to them.

  27. Posted August 16, 2017 at 6:49 am | Permalink

    We gave a preview of a theme we will be releasing soon for sale, Atlas. Perhaps that would be of interest.
    As for your theme, you would need to ask the developer of the theme. They would not want to be using flash in it since the reason we are removing flash is that browsers are no longer supporting flash and it’s best to move away from it.

  28. Bob McCown
    Posted August 18, 2017 at 4:54 pm | Permalink

    Are hashtags going to be supported across all modules? (forums and wall, specifically?)

  29. Posted August 21, 2017 at 6:43 am | Permalink

    Hashtags will be sitewide in our official modules (third parties may need to update their own code to work with our hashtags).

  30. Zsolt Envo Szrapkó
    Posted August 24, 2017 at 3:31 am | Permalink

    OR we need an ACTUAL modern javascript framework.

Post a Reply to Bob McCown

You must be logged in to Post a Comment.