Important compatibility fix for websites using PayPal

Paypal SSL 3.0 Poodle

If you use SocialEngine PHP and have PayPal enabled for collecting membership fees, this affects your site

We’ve recently received an email from PayPal titled “Immediate Action Required” in which they’ve mentioned that due to vulnerability to version 3 of Secure Sockets Layer (SSL 3.0), they will discontinue support for SSL 3.0 on December 3rd, 2014 at 8:01 a.m. You can read their official notification and reasoning behind it on their blog. This will cause compatibility issues in SocialEngine PHP powered sites when using PayPal as a payment gateway which will ultimately result in the inability of users to pay with PayPal. In order to avoid PayPal failure website administrators using PayPal as a gateway on their SocialEngine PHP website should apply the below code level change immediately.

We have created a support article that will guide you through the changes you need to make to keep Paypal running on your site.

We take such compatibility issues very seriously and dedicated our technical team to get this fix out right away after receiving PayPal’s notification. If you have any questions, please don’t hesitate to contact us.

This fix will be included in the 4.8.7 release of SocialEngine PHP.

Leave a comment

Your email address will not be published. Required fields are marked *